Protect your privacy on any device

Compatible with

compatible-os

Laptops and Desktops

  • PCs with Windows 7, Windows 8.x, or Windows 10 operating systems.
  • Intel-based Macs with OSX 10.5 (Leopard) through the latest 10.11 (El Capitan).

Tablet and Smartphones

  • iPhones, iPads and iPods running iOS6 or higher.
  • Android handsets and tablets running 4.1 (Jelly Bean) and above.